tweeeetyのぶろぐ的めも

アウトプットが少なかったダメな自分をアウトプット<br>\(^o^)/

npm

【gulp】gulp@4.0.0にしたら`The following tasks did not complete:`、`Did you forget to signal async completion?`と怒られる

はじめに とあることで、gulpを3.x.x.から^4.0.0にあげる必要がありました。 あげてからgulpタスクを実行すると 以下のようなエラーが出たのでその対応方法をメモ # defaultタスクを実行するとこんなエラーが... $ ./node_modules/gulp/bin/gulp.js [05:35:3…

【gulp】gulp@4.0.0にしたら`AssertionError [ERR_ASSERTION]: Task function must be specified`と怒られる

はじめに とあることで、gulpを3.x.x.から^4.0.0にあげる必要がありました。 あげてからgulpタスクを実行すると 以下のようなエラーが出たのでその対応方法をメモ # defaultタスクを実行するとこんなエラーが... $ ./node_modules/gulp/bin/gulp.js assert.j…

【node.js】npm@6にしたらnpm auditでpackageの脆弱性をチェックできるようになったメモ

はじめに npmコマンドを叩いた際に、@6.x.xにあげてねと言われました。 言われれるがままにあげてみたら npm auditも行えと言われてなんだこれ..と思って調べた自分用メモです。 画像元 アジェンダ npm auditとは "npm auditしてね"までの流れ npm auditの見…

【node.js】npmで`TypeError: require.extensions.hasOwnProperty is not a function`というエラーで怒られる

はじめに タイトルのまんまですが、 とあるプロジェクトでnpm runスクリプトを走らせると以下のようなエラーが出たのでその対処方メモ # nodeのversionをあげる $ nodebrew install v8.11.0 $ nodebrew use v8.11.0 # 念のため削除 $ rm -rf node_modules $ …

【node.js】ncu(npm-check-updates)でpackage.jsonのmodulesバージョンを一括で更新

はじめに npm-check-updates、いまさら感はありますが 使ってあらためて便利だったのでこの機会にメモ ncu(npm-check-updates)とは 公式URL npm-check-updates tjunnone/npm-check-updates 上記の公式からの引用です npm-check-updates allows you to upgr…

【node.js】npmで`SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode` というエラーで怒られる

はじめに タイトルのまんまですが、 とあるプロジェクトでnpm runスクリプトを走らせると以下のようなエラーが出たのでその対処方メモ $ npm run sample > hoge@1.0.0 sample /Users/tweeeety/hoge > gulp /Users/tweeeety/hoge/node_modules/riot-compiler/…

【node.js】node.jsのリリース状況やLTS(Long-Term-Support:長期サポート)やEOL(End-of-Life:サポート終了)を知る

はじめに node.jsやその周辺のversionが合わなくて環境がおかしい... そんなときにリリース状況やサポート状況を知りたい自分用メモです。 どこで知るか 以下で知れます nodejs/Release どんな感じか この記事時点での、ですがこんな感じで見れます。 Releas…